QuickMAR’s Upgrade to TLS 1.2

 

What is TLS?

TLS stands for “Transport Layer Security.” It is a protocol that provides privacy and data integrity between two communicating applications. It’s the most widely deployed security protocol used today and is used for web browsers and other applications that require data to be securely exchanged over a network. TLS ensures that a connection to a remote endpoint is the intended endpoint through encryption and endpoint identity verification.

What does this mean for QuickMAR customers?

CareSuite Manager: All browsers are updated and compatible.

Click on this link to confirm TLS 1.2 compatibility
Browser Compatibility List
How to update a web browser

CareSuite Client

Everyone must be upgraded to version 4.4 or above.  The goal is for all customers to update to 5.0.  All versions below 4.4 of the software will not be supported after December 2, 2019.

Upgrade all computers running QuickMAR to 5.0. Use this link to upgrade.

CareSuite RX

Everyone must be upgraded to Version 4.0 or higher.